
8. TUTORIAL FOR DECISION TREE ANALYSIS

*  Tutorial 8, May 2005

CASE: ICI AMERICAS R&D PROJECT SELECTION, P. 213

Decision tree analysis is useful to managers choosing among various courses of action when 
the choice (or sequence of choices) will ultimately lead to some uncertain consequences. The 
TreeÅge software allows you to take into account the potential payoffs, risks, and ambiguities 
associated with decisions when the decision process can be broken down into a sequence of 
actions and events. Payoffs are the monetary or other consequences of a decision; risks are 
the potential adverse consequences that may result from the decision because the decision 
maker lacks control over the consequences of the decision (i.e., he or she doesn’t know the 
outcomes with certainty), and ambiguities are imprecise information about payoffs and the 
degree of risk.

A decision tree analysis typically consists of four steps:

� Structuring the problem as a tree in which the end nodes of the branches are the 
payoffs associated with a particular path (scenario) along the tree.

� Assigning subjective probabilities to events represented on the tree.
� Assigning payoffs for consequences (dollar or utility value associated with a particular 

scenario). 
� Selecting course(s) of action based on analyses (e.g., rolling back of the tree, sen-

sitivity analyses, Monte Carlo simulations). We describe each step using the QRS 
Company, example, p.192, in the text.

TreeÅge is a comprehensive software package that includes a detailed online help fi le and 
an electronic manual. Here we describe only the features that you will need for the ICI case.

Note: To view or print a copy of the complete manual, you will need the original CD on 
which the Marketing Engineering software was distributed.
        If you do not have Adobe Acrobat‘ reader installed on your system, you can install it 
by downloading the appropriate fi les from www.adobe.com, or you can install the version 
supplied with the Marketing Engineering CD in the directory….\adobe.
 After Acrobat™ is successfully installed, start the Acrobat program. From the File 
menu, select Open and open the fi le manual.pdf from the x:\treeage\manuals directory, 
where x is the letter representing your CD-ROM drive. Under the File menu, select Print 
to print any part of the manual. 

STEP 1—STRUCTURING THE PROBLEM AS A DECISION TREE

To start the program go to Model and choose Decision Tree Analysis, you will see an empty 
root node from which you can construct a tree. To load a pre-existing tree, go to the File menu 
and select Open. (Choose the QRS.TRE fi le in the …/MktgEng/data directory to familiarize 
yourself with the software. If you load QRS.TRE, you can go directly to Step 2.)
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On the Options menu, select Add Branch or Insert Branch to add branches to any 
node on the tree. To delete a branch, click Delete Branch. 

Another method for adding branches to a node is to double-click on the node. When the 
cursor is over the node’s symbol, it will change to a branch cursor to indicate that double-
clicking will add branches. 

To indicate what a branch stands for, enter descriptive text in the box above it. Place 
the cursor above the line and click to get the box.

Note: Many decision trees have some subtree replication. You can cut and paste a subtree 
to other locations on the tree. Place the cursor at the root node of the subtree you want 
to copy and click. Go to the Options menu and click Select Subtree. Then go to the Edit 
menu and choose Copy Subtree. Next place the cursor on the node where you want to 
insert the subtree and click. Now go to the Edit menu and click Paste. You can cut and 
paste subtrees even after you assign names and probabilities to the branches and payoffs 
to the terminal nodes. (See also the Clone command under online Help.)
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The Edit menu contains four tree clipboards named Tree clipboard1 to Tree clipboard 
4. Thus, you can retain several subtrees at once, each in its own clipboard, to be pasted 
as needed.

STEP 2—ASSIGNING (CONDITIONAL) PROBABILITIES TO BRANCHES 
OF THE TREE

You can insert the probability of an outcome on the branch of the tree in the text box below the 
line. To get the text box, place the cursor below the line representing a branch and click.

NOTE: You can enter probabilities only on the branches of a tree that originate from a 
chance node. A decision tree contains several types of nodes:

1. A chance node (shown as a green circle) represents an uncertain or risky event. 
Branches emanating from a chance node represent all possible (non-overlapping) 
outcomes of the event.

2. A decision node (shown as a blue square) represents a decision the manager faces. 
Branches emanating from a decision node specify all available (non-overlapping) 
decision choices.

3. A terminal node (shown as a red triangle) represents a fi nal outcome: the end of a 
path, often referred to as a scenario. 

     To change a node type, click the node, go to the Options menu and click Change 
Node Type and select the node type from the available choices. Alternatively, you can 
click the     icon on the toolbar and select the node type you want.

As an exercise, construct the tree shown below:
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In the rest of the text under Step 2, we describe advanced features. You can skip to Step 
3 until you become familiar with the software. 

In many cases, you will be uncertain about the accuracy of your probability estimates. Defi ning 
the probabilities as variables will enable you to perform sensitivity analyses to help you assess the 
signifi cance of the uncertainty. To do this, you must defi ne the variable, specify the value(s) it can 
take, and indicate the location(s) on the decision tree where these values will apply:

1. Defi ne a variable: Go to the Values menu and choose Defi ne Values. Click New 
and select Variable from the drop-down menu. 
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    In the Text Properties section of the Properties dialog box, give your variable a 
name. If you like, you can also provide a short description or a longer comment, 
which can be useful for customizing the display,

Follow the above procedure to defi ne each variable in your model. 

2. Specify the default value and, optionally, the range of values a variable takes. Use 
the Value Properties section to specify a default value (baseline value) for a variable 
and a range of numeric values to be associated with it. For example, p1 could have 
the default value of 0.8 and values ranging from 0.6 to 0.9. You can accept or over-
ride the suggested range when specifying the parameters of the sensitivity analyses. 
It is not necessary to provide a range here, although you may fi nd it convenient. 

3. Indicate the locations on the tree where the values apply. Click on Value, and 
you will be presented with two options. Either you can defi ne a value at a particular 
node or as a default for the whole tree. If you defi ne a variable at a particular node, 
the program applies that value of the variable throughout the subtree rooted at the 
selected node. If you defi ne a variable as the default for the tree, it applies to the 
entire tree, and its defi nition resides at the root node. Node-specifi c defi nitions are 
appropriate for probabilities whose values are likely to differ at various points on the 
tree, for example, the probabilities of high and low sales would depend on whether 
market research results were favorable. Default defi nitions are appropriate for prob-
abilities whose values remain constant throughout the tree, for example, the rate of 
infl ation.
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4. Associate the variable with probabilities on the tree: Insert the variable name in 
the text box below the branches of the tree for which the variable will represent the 
probability value. In the example below, p1 represents the probability of “High Sales” 
under the “Make New Product” and “Great Survey Results” scenario. 

Note: The probabilities along the branches emanating from each chance node must sum 
to 1.0. Thus, if two branches emanate from a chance node, you can assign one the vari-
able p1 and the other (1 - p1).
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It is very important to make the variable assignments at the correct nodes. For this, you 
need to understand how the program uses variables in making calculations. 

When the program encounters a variable in a probability fi eld during calculations, it 
searches for the value assignment beginning with the node immediately to the right of the 
probability fi eld and moves from there leftward to the root node. For a given variable, the 
program accepts the fi rst defi nition (value assignment) that it locates as it makes this traversal. 
Thus, the program will disregard any defi nitions closer to the terminal node than the node 
immediately to the right of the probability fi eld in question.

As a general rule, you should avoid using the same variable to defi ne the probability 
of more than one event. Thus, if you have two subtrees representing the same uncertainty 
(high versus low sales), but the probability values are different, you should use different 
variables.

STEP 3—ASSIGNING PAYOFFS (PREFERENCES) FOR SCENARIOS

If you are sure about the dollar value (payoff) associated with a scenario, fi rst select the 
terminal node (place the cursor on the node and click) and then go to the Options menu and 
select Change Node Type. You can also click on the           icon to change the node type. 
You will see the following dialog box:

Select the terminal node option (red triangle) and click OK.
You will be prompted to enter a numerical value for Payoff 1. You can then enter the 

sure payoffs. You can associate up to four different payoffs with each scenario (e.g., dollar 
value, costs, utility value, or payoff realized by a partner fi rm). In the following example, 
we selected the terminal node under High Sales, which is under the Great Survey Results 
scenario, and entered the value eighty-four.

Enter a payoff for each terminal node.
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In the rest of the text under Step 3, we describe advanced features. You can skip to Step 
4 until you become familiar with the software.

For conducting sensitivity analyses, you can defi ne variables to denote payoffs. The 
procedure for defi ning variables for payoffs is the same as the one we described for assigning 
variables for probabilities. In the following example, we will use the variable v1 to represent 
payoffs realized under High Sales and with No Market Survey. You can also use algebraic 
expressions of defi ned variables (e.g., v1 + v2 - v3) to represent more complex payoffs.

For variables used in calculating payoffs for a scenario, the program will search each 
node in the scenario, beginning with the terminal node and traversing leftward to the root 
node, looking for numeric defi nitions for each relevant variable. For a given variable, the 
program will accept the fi rst defi nition (value assignment) that it locates on this traversal. 
Thus, if the same construct will have different values at two different nodes on the tree, it is 
best to defi ne two separate variables that apply at those nodes. For example, if unit costs of 
production are higher at higher volumes, then the cost fi gures in scenarios with high sales 
should have larger numbers than cost fi gures in scenarios that call for lower sales. 

Click the Distribution button to specify the frequency with which values of the vari-
able would be selected in Monte Carlo analyses. In the example below, we fi rst selected the 
Normal distribution from the palette of distributions and then specifi ed a mean of -66 and 
a standard deviation of 5.0 for variable v1. 
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STEP 4—CONDUCTING ANALYSES TO SELECT DECISION OPTION(S)
You can conduct many types of analyses with the TreeÅge software. We will describe 

those you are most likely to use for the ICI exercise. To learn about other types of analyses, 
play around with the other commands on the Analysis menu, which are described in the 
online help fi les.

Calculate the expected value of a node: Click on a node, go to the Analysis menu and 
select Expected Value. A dialog box will show the expected value; in this example, the 
expected value of the Take Market Survey node is $8. 

Note: In calculating the expected value, the program uses the baseline values of variables 
or the mean values of distributions associated with the variables.
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Rolling back the tree: Instead of calculating the expected value of each node in the tree 
individually, you can calculate and display the expected values and probabilities of all nodes 
simultaneously. To do this, go to the Analysis menu and click Roll Back. Alternatively, you 
can click on the        icon on the tool bar.

Once you roll back the tree, you will see three additional pieces of information on the tree: 

� The expected payoffs (in dollars or other appropriate units) shown in a rectangular 
box at each chance and decision node.

� The payoff and the overall probability for each terminal node.
� The path along the tree that leads to the highest expected payoff (the branches that 

are not along this path are marked with the symbol \\). In this example, the “optimal” 
decision is to make the new product without conducting a market survey.

Sensitivity analyses: The TreeÅge software offers several options for conducting sen-
sitivity analyses to determine which factors have great impact on the decisions. The most 
common way to do this is to select a node and then go to the Analysis menu and select 
Sensitivity Analysis. You will then have four choices: 
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� Analyzing the effects of a change in one variable (One-way).
� Analyzing the effects of changes in any two variables simultaneously (Two-way).
� Analyzing the effects of changes in any three variables simultaneously (Three-

way).
� Tornado diagram, which is a set of one-way sensitivity analyses on any subgroup 

of variables in your decision tree. We describe the one-way graphs and Tornado 
diagrams.

One-Way Sensitivity Analysis: If you choose One-way, you will see the following 
screen. 

Note: It is important to fi rst specify the node at which this analysis will apply. Typically, 
you would select the root node to see the impact of the sensitivity analysis on the overall 
decision.

After you specify the variable of interest and its range of variation, click OK. You will 
then see a chart showing how the expected value of each decision option changes as the 
value of the selected variable changes.

In the following example, the analysis indicates that if p1 (probability of High Sales 
given Great Survey Results) is equal to a little over 0.84, then it may pay to conduct a test 
market survey.
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On the File menu, click Close to get back to the decision tree display. 
Tornado Diagram: An alternative way to conduct sensitivity analyses is the Tornado 

diagram, which is a set of mini-sensitivity analyses set forth in a single graph. It can include 
all or a subset of the variables defi ned in your tree. You specify which variables are to be 
included in the analysis and assign a range of values to each of them. In the resulting graph, 
each variable analyzed is represented by a horizontal bar. Each bar represents the range of 
possible outcomes generated by varying the related variable. A wide bar indicates that the 
associated variable has a large potential effect on the expected value of the decision. This 
is called a tornado diagram because the bars are arranged in order with the widest bar at 
the top and narrowest bar at the bottom, resulting in a funnel-like appearance. A vertical 
dotted line is drawn on the graph to indicate the expected value at the selected node (often 
the root node).

To construct a tornado diagram, select the chance node or decision node at which you 
want to construct the diagram. Next from the Analysis menu, select Tornado Diagram 
and then select Variables to Analyze. Click each variable to be included (from Available 
Variables) and then click Add>>. You will be prompted to specify the range of variation 
for each variable.
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Once you enter the appropriate information, the program will display the results of 
the sensitivity analysis as bar graphs indicating the expected payoff as the values of the 
variable(s) change. 

Note: The vertical dotted line at the selected node is the “fulcrum” that allows you to 
view the impact of each variable relative to the original (baseline) expected value. Thus, 
although the range of p1 is from 0.6 to 0.9, it affects the expected value of the decision 
only for values from 0.84 to 0.9 - the range in which the expected value of the decision 
becomes higher than 10, the baseline. 
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Monte Carlo analysis: In Monte Carlo analysis, the model runs a number of simulated 
trials. The result of each trial is a single scenario selected according to the probabilities 
specifi ed in the model. On most decision trees, no specifi ed outcome corresponds to the 
expected value. The results from the simulation are a distribution of payoffs rather than a 
single expected value. Over many simulation trials, the average result will fall very close 
to the expected value, but you will also obtain information about the variance around the 
expected value. You can fi nd more details about the Monte Carlo analysis in the online help 
and in the detailed manual for the program that you can print out as we described at the 
beginning of this tutorial. 

LIMITATIONS OF THE EDUCATIONAL VERSION OF THE SOFTWARE

The educational (demonstration) version of TreeÅge is identical to the full version in 
most respects, except:

� You cannot save any documents. Once you complete an exercise, you cannot store 
the tree for future use (although you can print out a copy from which you can recon-
struct the tree). So, do not exit the program until you are sure you have completed 
all analyses. 

� The maximum size tree you can create manually is 50 nodes.
� The maximum size tree you can open is 125 nodes. We have included several example 

fi les (with extension *.tre) that you can open to learn more about how decision trees 
are used in various application areas.


